import re
regex = re.compile(r"([^' \"\n]+)\.([^ \n]+)&((?![\"'])[^ \"'\n])+($|(?=\s))", flags=re.MULTILINE)
test_str = ("google.com/cool?cool1=yes&cool2=no&cool3=no\"\n\n"
"google.com/cool?cool1=yes&cool2=no&cool3=no\n\n"
"url.com¶meter url2.com¶meter")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")