# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\bBEGIN\b([\w\n]*?)\bEND\b\n)//g;t' <<< "a
b
BEGIN
c
d
e
END
f
g
h
i
j
BEGIN
k
l
m
n
o
p
q
END
r
s
t
u
v
BEGIN
w
x
y
END
z"