# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\bBEGIN\b([\w\n]*?)\bEND\b\n)"
test_str = ("a\n"
"b\n"
"BEGIN\n"
"c\n"
"d\n"
"e\n"
"END\n"
"f\n"
"g\n"
"h\n"
"i\n"
"j\n"
"BEGIN\n"
"k\n"
"l\n"
"m\n"
"n\n"
"o\n"
"p\n"
"q\n"
"END\n"
"r\n"
"s\n"
"t\n"
"u\n"
"v\n"
"BEGIN\n"
"w\n"
"x\n"
"y\n"
"END\n"
"z")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.