package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\bBEGIN\b([\w\n]*?)\bEND\b\n)`)
var str = `a
b
BEGIN
c
d
e
END
f
g
h
i
j
BEGIN
k
l
m
n
o
p
q
END
r
s
t
u
v
BEGIN
w
x
y
END
z`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}