$re = '/(\bBEGIN\b([\w\n]*?)\bEND\b\n)/';
$str = 'a
b
BEGIN
c
d
e
END
f
g
h
i
j
BEGIN
k
l
m
n
o
p
q
END
r
s
t
u
v
BEGIN
w
x
y
END
z';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;