using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\bBEGIN\b([\w\n]*?)\bEND\b\n)";
string substitution = @"";
string input = @"a
b
BEGIN
c
d
e
END
f
g
h
i
j
BEGIN
k
l
m
n
o
p
q
END
r
s
t
u
v
BEGIN
w
x
y
END
z";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}