#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{2}\/\d{2}\/\d{4}\s\d{2}:\d{2}"
Local $sString = "yyyy/MM/dd HH:mm" & @CRLF & _
"2017/08/26 12:02" & @CRLF & _
"" & @CRLF & _
"dd/MM/yyyy HH:mm" & @CRLF & _
"" & @CRLF & _
"26/08/2017 12:02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")