using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}\/\d{2}\/\d{4}\s\d{2}:\d{2}";
string input = @"yyyy/MM/dd HH:mm
2017/08/26 12:02
dd/MM/yyyy HH:mm
26/08/2017 12:02";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}