import re
regex = re.compile(r"\d{2}\/\d{2}\/\d{4}\s\d{2}:\d{2}", flags=re.MULTILINE)
test_str = ("yyyy/MM/dd HH:mm\n"
"2017/08/26 12:02\n\n"
"dd/MM/yyyy HH:mm\n\n"
"26/08/2017 12:02")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")