#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\\"
Local $sString = "D:\Test\Folder\file1.txt" & @CRLF & _
"D:\Test\Folder\Folder\file2.txt" & @CRLF & _
"D:\file3.txt" & @CRLF & _
"D:\Folder\file1.txt" & @CRLF & _
"D:\Test\Test2\file1.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")