$re = '/\\\\/m';
$str = 'D:\\Test\\Folder\\file1.txt
D:\\Test\\Folder\\Folder\\file2.txt
D:\\file3.txt
D:\\Folder\\file1.txt
D:\\Test\\Test2\\file1.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);