using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\";
string input = @"D:\Test\Folder\file1.txt
D:\Test\Folder\Folder\file2.txt
D:\file3.txt
D:\Folder\file1.txt
D:\Test\Test2\file1.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}