re = /\\/m
str = 'D:\\Test\\Folder\\file1.txt
D:\\Test\\Folder\\Folder\\file2.txt
D:\\file3.txt
D:\\Folder\\file1.txt
D:\\Test\\Test2\\file1.txt
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end