// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\").unwrap();
let string = "D:\\Test\\Folder\\file1.txt
D:\\Test\\Folder\\Folder\\file2.txt
D:\\file3.txt
D:\\Folder\\file1.txt
D:\\Test\\Test2\\file1.txt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}