package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\`)
var str = `D:\Test\Folder\file1.txt
D:\Test\Folder\Folder\file2.txt
D:\file3.txt
D:\Folder\file1.txt
D:\Test\Test2\file1.txt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}