# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Past 30 Days\s*)([^-]*)([^]]+)/$1$3$2/g;t' <<< "Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]
Radio Stations-Listened to Past Week-Quebec City [FM-CFEL-102.1 (blvd 102.1)]"