const regex = /(Past 30 Days\s*)([^-]*)([^]]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Past 30 Days\\s*)([^-]*)([^]]+)', 'g')
const str = `Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]
Radio Stations-Listened to Past Week-Quebec City [FM-CFEL-102.1 (blvd 102.1)]`;
const subst = `$1$3$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);