import Foundation
let pattern = #"(Past 30 Days\s*)([^-]*)([^]]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]
Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]
Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]
Radio Stations-Listened to Past Week-Quebec City [FM-CFEL-102.1 (blvd 102.1)]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)