import re
regex = re.compile(r"(Past 30 Days\s*)([^-]*)([^]]+)")
test_str = ("Internet-Devices Used to Access Internet Past 30 Days [Desktop Computer-Owned by Self]\n"
"Internet-Devices Used to Access Internet Past 30 Days [Tablet-Owned by Other HH Member]\n"
"Internet-Devices Used to Access Internet Past 30 Days [Laptop Computer-Made Available by Your Employer]\n"
"Radio Stations-Listened to Past Week-Quebec City [FM-CFEL-102.1 (blvd 102.1)]")
subst = "$1$3$2"
result = regex.sub(subst, test_str)
if result:
print(result)