using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?>""[^""]*""|[^"">]+)*>(*SKIP)(*F)|(?<=[A-Za-z])=+(?=(?>""[^""]*""|[^""<]+)+<\/)";
string substitution = @"|";
string input = @"<DT><H3 ADD_DATE=""1727566144"" LAST_MODIFIED=""1727566144"">produksjonsunderlag=production basis=()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE=""1727566144"" LAST_MODIFIED=""1727566144"">produksjonsunderlag|production basis|()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE=""1727566144"" LAST_MODIFIED=""1727566144"">antitrust==(مكافحة الاحتكار)</H3>
<DL><p>
<DT><H3 ADD_DATE=""1727566144"" LAST_MODIFIED=""1727566144"">**antitrust|(مكافحة الاحتكار)**</H3>
<DL><p> ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}