import re
regex = re.compile(r"<(?>\"[^\"]*\"|[^\">]+)*>(*SKIP)(*F)|(?<=[A-Za-z])=+(?=(?>\"[^\"]*\"|[^\"<]+)+<\/)")
test_str = ("<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">produksjonsunderlag=production basis=()(أساس الإنتاج )</H3> \n\n"
"<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">produksjonsunderlag|production basis|()(أساس الإنتاج )</H3> \n\n"
"<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">antitrust==(مكافحة الاحتكار)</H3>\n"
"<DL><p> \n\n"
"<DT><H3 ADD_DATE=\"1727566144\" LAST_MODIFIED=\"1727566144\">**antitrust|(مكافحة الاحتكار)**</H3>\n"
"<DL><p> ")
subst = "|"
result = regex.sub(subst, test_str)
if result:
print(result)