import Foundation
let pattern = #"<(?>"[^"]*"|[^">]+)*>(*SKIP)(*F)|(?<=[A-Za-z])=+(?=(?>"[^"]*"|[^"<]+)+<\/)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">produksjonsunderlag=production basis=()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">produksjonsunderlag|production basis|()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">antitrust==(مكافحة الاحتكار)</H3>
<DL><p>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">**antitrust|(مكافحة الاحتكار)**</H3>
<DL><p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)