const regex = /<(?>"[^"]*"|[^">]+)*>(*SKIP)(*F)|(?<=[A-Za-z])=+(?=(?>"[^"]*"|[^"<]+)+<\/)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?>"[^"]*"|[^">]+)*>(*SKIP)(*F)|(?<=[A-Za-z])=+(?=(?>"[^"]*"|[^"<]+)+<\\\/)', 'g')
const str = `<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">produksjonsunderlag=production basis=()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">produksjonsunderlag|production basis|()(أساس الإنتاج )</H3>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">antitrust==(مكافحة الاحتكار)</H3>
<DL><p>
<DT><H3 ADD_DATE="1727566144" LAST_MODIFIED="1727566144">**antitrust|(مكافحة الاحتكار)**</H3>
<DL><p> `;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);