# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)<a .*?href=\"(.*?)\".*?>(.*?)<\/a>(.*)/\1[\3](\2)\4/gm;t' <<< "This is <a href=\"www.google.com/search?q=2\">hyperlink</a>. You can click this."