re = /(.*?)<a .*?href=\"(.*?)\".*?>(.*?)<\/a>(.*)/m
str = 'This is <a href="www.google.com/search?q=2">hyperlink</a>. You can click this.'
subst = '\\1[\\3](\\2)\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result