import re
regex = re.compile(r"(.*?)<a .*?href=\"(.*?)\".*?>(.*?)</a>(.*)", flags=re.MULTILINE)
test_str = "This is <a href=\"www.google.com/search?q=2\">hyperlink</a>. You can click this."
subst = "\\1[\\3](\\2)\\4"
result = regex.sub(subst, test_str)
if result:
print(result)