const regex = new RegExp('(.*?)<a .*?href=\\"(.*?)\\".*?>(.*?)</a>(.*)', 'gm')
const str = `This is <a href="www.google.com/search?q=2">hyperlink</a>. You can click this.`;
const subst = `\1[\3](\2)\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);