using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)<a .*?href=\""(.*?)\"".*?>(.*?)</a>(.*)";
string substitution = @"\1[\3](\2)\4";
string input = @"This is <a href=""www.google.com/search?q=2"">hyperlink</a>. You can click this.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}