import Foundation
let pattern = #"(.*?)<a .*?href=\"(.*?)\".*?>(.*?)</a>(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This is <a href="www.google.com/search?q=2">hyperlink</a>. You can click this."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1[\3](\2)\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)