#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)\[([^\]]+)\]\(([^)]+(.md))\)"
Local $sString = "[test](test.md) [test](test.md) [test](test.md)" & @CRLF & _
"- [Standard Rewards](Standard%20Rewards.md)" & @CRLF & _
"- [Highest Exp Char](Exp%20Char.md)" & @CRLF & _
"- [Highest Exp Fairies](Crystals%20Fairy%20Exp.md)"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)