re = /\[([^\]]+)\]\(([^)]+(.md))\)/mi
str = '[test](test.md) [test](test.md) [test](test.md)
- [Standard Rewards](Standard%20Rewards.md)
- [Highest Exp Char](Exp%20Char.md)
- [Highest Exp Fairies](Crystals%20Fairy%20Exp.md)'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result