using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\]]+)\]\(([^)]+(.md))\)";
string substitution = @"$3";
string input = @"[test](test.md) [test](test.md) [test](test.md)
- [Standard Rewards](Standard%20Rewards.md)
- [Highest Exp Char](Exp%20Char.md)
- [Highest Exp Fairies](Crystals%20Fairy%20Exp.md)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}