package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[([^\]]+)\]\(([^)]+(.md))\)`)
var str = `[test](test.md) [test](test.md) [test](test.md)
- [Standard Rewards](Standard%20Rewards.md)
- [Highest Exp Char](Exp%20Char.md)
- [Highest Exp Fairies](Crystals%20Fairy%20Exp.md)`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}