import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\]]+)\\]\\(([^)]+(.md))\\)";
final String string = "[test](test.md) [test](test.md) [test](test.md)\n"
+ "- [Standard Rewards](Standard%20Rewards.md)\n"
+ "- [Highest Exp Char](Exp%20Char.md)\n"
+ "- [Highest Exp Fairies](Crystals%20Fairy%20Exp.md)";
final String subst = "$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}