use strict;
my $str = '[test](test.md) [test](test.md) [test](test.md)
- [Standard Rewards](Standard%20Rewards.md)
- [Highest Exp Char](Exp%20Char.md)
- [Highest Exp Fairies](Crystals%20Fairy%20Exp.md)';
my $regex = qr/\[([^\]]+)\]\(([^)]+(.md))\)/mip;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";