using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\(]*) #first group stores function name
\( #starting parenthesis
(?:\b([^\)\(\]\[\}\{]+)\b)? #second group saves parameters passed to function
\) #closing parenthesis";
string input = @"print(float(addthese(int(((1)+(2)+aval())),1)))";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}