// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)([^\(]*) #first group stores function name
\( #starting parenthesis
(?:\b([^\)\(\]\[\}\{]+)\b)? #second group saves parameters passed to function
\) #closing parenthesis").unwrap();
let string = "print(float(addthese(int(((1)+(2)+aval())),1)))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}