const regex = new RegExp('([^\\(]*) #first group stores function name
\\( #starting parenthesis
(?:\\b([^\\)\\(\\]\\[\\}\\{]+)\\b)? #second group saves parameters passed to function
\\) #closing parenthesis', 'g')
const str = `print(float(addthese(int(((1)+(2)+aval())),1)))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}