use strict;
my $str = 'print(float(addthese(int(((1)+(2)+aval())),1)))';
my $regex = qr/([^\(]*) #first group stores function name
\( #starting parenthesis
(?:\b([^\)\(\]\[\}\{]+)\b)? #second group saves parameters passed to function
\) #closing parenthesis/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}