re = /([^\(]*) #first group stores function name
\( #starting parenthesis
(?:\b([^\)\(\]\[\}\{]+)\b)? #second group saves parameters passed to function
\) #closing parenthesis/x
str = 'print(float(addthese(int(((1)+(2)+aval())),1)))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end