import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\(]*) #first group stores function name \n"
+ "\\( #starting parenthesis\n"
+ "(?:\\b([^\\)\\(\\]\\[\\}\\{]+)\\b)? #second group saves parameters passed to function\n"
+ "\\) #closing parenthesis";
final String string = "print(float(addthese(int(((1)+(2)+aval())),1)))";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}