#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(\w)\w+(?:(?:\s+\w+)*?\s+\1\w+){3}"
Local $sString = "cat take boom candle creepy drum cheek " & @CRLF & _
"cat color coral chat" & @CRLF & _
"" & @CRLF & _
"c c c c" & @CRLF & _
"ca c ca c ca c ca"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")