re = /\b(\w)\w+(?:(?:\s+\w+)*?\s+\1\w+){3}/m
str = 'cat take boom candle creepy drum cheek
cat color coral chat
c c c c
ca c ca c ca c ca'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end