using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\w)\w+(?:(?:\s+\w+)*?\s+\1\w+){3}";
string input = @"cat take boom candle creepy drum cheek
cat color coral chat
c c c c
ca c ca c ca c ca";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}