import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(\\w)\\w+(?:(?:\\s+\\w+)*?\\s+\\1\\w+){3}";
final String string = "cat take boom candle creepy drum cheek \n"
+ "cat color coral chat\n\n"
+ "c c c c\n"
+ "ca c ca c ca c ca";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}