import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*((^\\.)|(^\\s)|(\\.$)|(\\s$)|[\\x00-\\x1F\\x7F<>:\\\"\\/\\\\|?*]|((?i)^CON$|^PRN$|^AUX$|^NUL$|^COM[0-9]$|^COM[\\u00B9\\u00B2\\u00B3]$|^LPT[0-9]$|^LPT[\\u00B9\\u00B2\\u00B3]$))).*$";
final String string = "📂📂文件(夹)名称验证uD83DuDCC2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}