import re
regex = re.compile(r"^(?!.*((^\.)|(^\s)|(\.$)|(\s$)|[\x00-\x1F\x7F<>:\"\/\\|?*]|((?i)^CON$|^PRN$|^AUX$|^NUL$|^COM[0-9]$|^COM[\u00B9\u00B2\u00B3]$|^LPT[0-9]$|^LPT[\u00B9\u00B2\u00B3]$))).*$", flags=re.MULTILINE)
test_str = "📂📂文件(夹)名称验证uD83DuDCC2"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")