use strict;
my $str = '📂📂文件(夹)名称验证uD83DuDCC2';
my $regex = qr/^(?!.*((^\.)|(^\s)|(\.$)|(\s$)|[\x00-\x1F\x7F<>:\"\/\\|?*]|((?i)^CON$|^PRN$|^AUX$|^NUL$|^COM[0-9]$|^COM[\u00B9\u00B2\u00B3]$|^LPT[0-9]$|^LPT[\u00B9\u00B2\u00B3]$))).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}