using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*?(\S).*\1.*\1)(?:\b ?[a-f\d]{2}){16}$";
string input = @"Valid matches examples:
33 e0 f1 76 9c 4f a8 6c 01 5d 45 9e 28 db 7b 2a
Invalid matches examples:
c0 b0 f5 60 02 8b 1c a4 41 7c 53 f2 85 20 a0 d1
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}