const regex = /^(?!.*?(\S).*\1.*\1)(?:\b ?[a-f\d]{2}){16}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*?(\\S).*\\1.*\\1)(?:\\b ?[a-f\\d]{2}){16}$', 'gm')
const str = `Valid matches examples:
33 e0 f1 76 9c 4f a8 6c 01 5d 45 9e 28 db 7b 2a
Invalid matches examples:
c0 b0 f5 60 02 8b 1c a4 41 7c 53 f2 85 20 a0 d1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}